2009年2月17日 星期二

Google Earth 5 beta on Ubuntu 8.10 AMD64

※以下提到的問題,在Ubuntu 9.04中已經解決。

這個beta版果然是不負其名,問題一堆,比4.3版還誇張...。

以下用Google Earth 5.00.11337.1968作為例子,在這之後的版本可能會修正以下的問題。

  1. 無 法啟動或啟動一會之後掛掉,會顯示「version OPENSSL_0.9.8 not defined in file libcrypto.so.0.9.8 with link time reference」。解決的方法很簡單,把GE安裝目錄下的libcrypto.so.0.9.8刪除或改名就行,或以系統內建的檔案取代。來源

  2. 中文無法顯示、字型顯示效果很差。同4.3版的解法,把Google Earth附帶的libQT4函式檔以系統內建的檔案取代。來源

  3. 無法顯示圖片。不知這是不是更換QT4函式的後遺症,這個問題無法修正,只能等Google解決。


如果你懶得找檔案,這裡有從i386版整理好的函式庫,解壓縮後複製到Google Earth安裝目錄即可。